Telephone communication outage
Incident Report for Coreix
Resolved
Telephone services are now operational. Normal method of communication can now resume.
Posted about 1 year ago. May 26, 2017 - 16:29 BST
Investigating
All calls to and from Coreix Ltd cannot be completed. It is recommended that email or live chat is employed as an alternative for the time being.
Posted about 1 year ago. May 26, 2017 - 16:15 BST