Reduced Support Capabilities - Enfield DC
Incident Report for Coreix
Resolved
Our support team is now back on site and full service resumed.
Posted about 1 month ago. Nov 01, 2017 - 09:53 GMT
Investigating
Due to a power incident affecting another datahall at our Enfield facility the technical team has been evacuated from the site for safety purposes. Our team continues to support requests remotely at this time.
Posted about 1 month ago. Nov 01, 2017 - 08:33 GMT