Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 17, 2025 - 20:00 BST
Update
The planned Maintenance of BE Client Management Services has been moved to August 17th 2025 (17/08/2025) 20.00hrs to August 17th 2025 (17/08/2025) 21.30hrs
Posted Aug 14, 2025 - 13:15 BST
Scheduled
+Be Client Management Service will be undergoing scheduled maintenance up to one (1) hour and thirty (30) Minutes.
During this time, response times of the Support Team to queries/Tickets & access to the Customer Portal will be affected.
It is recommended that all emails to the Technical Support Team & Network Team (servicedesk@bec.uk) be accompanied by a telephone call to BE Support Telephone Number: 02045703156.
This is a singular necessary planned maintenance upgrade to the Client Management Service.
We apologise for the inconvenience caused, but necessary maintenance is often unavoidable in an effort to be proactive. We will update you upon completion of the task planned, marking this notification as "Resolved" on the status page.