Telehouse North - UPS System B – Module 1 Alarm

Incident Report for BE

Identified

Repair work is to be conducted today. Please note that the system remains stable with full N+1 redundancy in place.

There continues to be no impact to critical IT power.

Further updates will be provided as the situation progresses.
Posted Jul 08, 2025 - 14:26 BST

Investigating

Be has received a notification from Telehouse of an alarm raised on UPS System B, Module B1. The system remains stable with N+1 redundancy fully maintained, and there is no impact to critical IT power.

As a precautionary measure, Telehouse are closely monitoring the system while their investigation is ongoing.

Telehouse's specialist vendor is scheduled to attend site on Monday, 07/07/2025, to work alongside their onsite team to complete the investigation. Telehouse will provide a further update once their UPS System Specialist is onsite to begin diagnostic testing and fault analysis.

We appreciate your continued patience and understanding.

If you have any immediate concerns or questions, please contact our 24/7 Service Desk at servicedesk@bec.uk
Posted Jul 06, 2025 - 17:16 BST
This incident affects: Facilities (Docklands).