Power resiliency Virtus Hayes Data Centre

Incident Report for Coreix

Resolved

This incident has been resolved.
Posted 7 days ago. Mar 26, 2025 - 13:23 GMT

Identified

Today at 02.53hrs GMT North Hayes Electrical Power Station caught fire ceasing power supply to Heathrow Airport & surrounding areas. As a precaution Virtus Hayes Data Centre has taken the action of using the Diesel Generators for powering the Data Centre.

Further information will be given as the situation progresses.
Posted 12 days ago. Mar 21, 2025 - 11:27 GMT
This incident affected: Facilities (DC5 - Hayes).