Telehouse East: UPS System D – Intermittent Communications Failure Alarm

Incident Report for BE

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 14:09 BST

Identified

The UPS was switched to maintenance bypass, allowing the vendor to carry out the repairs. The customer loads connected to the UPS are currently supported by the generator. All customer loads remain stable on the primary utility source. There is no customer impact.
Posted Aug 20, 2025 - 14:22 BST

Investigating

An intermittent Communications alarm has been detected on UPS System D, located within the Telehouse East Building.
The onsite team has confirmed that the critical I.T load remains fully supported.

UPS vendor has been called out and is expected to arrive on-site at 06:30hrs to carry out further investigation and support the resolution.
Posted Aug 19, 2025 - 06:33 BST
This incident affected: Facilities (Docklands).